Page 1 of 1

OMERO.web logs me out after login

PostPosted: Mon Oct 09, 2017 5:44 pm
by cagancayco
Hi, I am trying to install OMERO.web and OMERO.server on an AWS EC2 Ubuntu 16.04 instance. I successfully installed OMERO 5.3.4 on Monday October 2 and over the next two days I was able to upload images, create new groups/users, and access the server with OMERO.insight. On Thursday Oct 5 when I tried to log on with any account, including root, through OMERO.web I was immediately kicked out or was given the error below. I tried installing OMERO 5.3.5 on a fresh instance but was getting the same errors, and just now I am getting this with a newly installed OMERO 5.4.0. I haven't been able to get the error message with OMERO 5.4.0 though. I've tried fresh installs several times and still get the same issue.

I am still able to use OMERO.cli and OMERO.insight to import and view images, so I'm not sure what's going on. I am using Chrome now, but I tried Firefox and Safari on Friday and still ran into the same issue. Any tips or insight is greatly appreciated. -Christina

{"stacktrace": "Traceback (most recent call last):\n File \"/home/omero/\", line 1288, in wrap\n server_id = request.session['connector'].server_id\n File \"/usr/local/lib/python2.7/dist-packages/django/contrib/sessions/backends/\", line 48, in __getitem__\n return self._session[key]\nKeyError: 'connector'\n", "message": "'connector'"}

Re: OMERO.web logs me out after login

PostPosted: Tue Oct 10, 2017 11:14 am
by kennethgillen
Hi Christina,

Is OMERO.web on a separate instance?

Did OMERO.web work from Oct 2nd? i.e. you say it was not working on Oct5th, it'd be good to know if it worked before that point.

It would help us work out what's going wrong with more of the logs - at least the full file you're quoting, and potentially the OMERO configuration. The server's Blitz logs would be good to have as well, so perhaps send us the whole log directory?

Could you please upload the following to

  • Output of bin/omero admin diagnostics
  • Output of bin/omero config get --hide-password (Blank out any passwords)
  • OMERO.server logs: ${OMERO_SERVER}/var/log

We recently announced a secvuln where the workaround would stop OMERO.web connecting if a config value wasn't also applied [1], but a fresh 5.3.5 or 5.4.0 should not require this to be applied.

It would also be useful to know what set of installation instructions you are following?

[1] ... uest-user/

Many thanks,


Re: OMERO.web logs me out after login

PostPosted: Tue Oct 10, 2017 12:48 pm
by cagancayco
Hi Kenny,

I just uploaded the logs, hopefully this helps!

I have OMERO.web and OMERO.server installed on the same instance using the same dedicated omero user, although I did install OMERO.server using virtualenv. I will try installing them on separate instances. OMERO.web did work from October 2nd until the middle of the day October 5th--I had created a few test users and logged in as each to see the sharing permissions I set were working properly.

I used the following instructions for install.

OMERO.server: ... ice36.html
OMERO.web (option 1): ... ce3.6.html

Thank you!

Re: OMERO.web logs me out after login

PostPosted: Tue Oct 10, 2017 3:02 pm
by cagancayco
I think I fixed my error... I had started OMERO.web using the OMERO.server/bin/omero instead of since I had added the OMERO.server/bin/omero to my path in the .bashrc. I will let you know if the problem arises again. Thank you!

Re: OMERO.web logs me out after login

PostPosted: Thu Oct 12, 2017 5:36 am
by kennethgillen
We're glad you got it sorted.

You may wish to consider adding the init.d scripts which allow OMERO to be started and stopped like a regular system service, including at boot time. ... ero-server ... -omero-web