We're Hiring!

virtual appliance - help

General user discussion about using the OMERO platform to its fullest. Please ask new questions at https://forum.image.sc/tags/omero
Please note:
Historical discussions about OMERO. Please look for and ask new questions at https://forum.image.sc/tags/omero

There are workflow guides for various OMERO functions on our help site - http://help.openmicroscopy.org

You should find answers to any basic questions about using the clients there.

virtual appliance - help

Postby Vanhecke » Wed Jan 18, 2012 8:16 am

Hi All,

We are interested in implementing OMERA for our microscopy lab. This involves about 20 scientists and several methods (we have a confocal, several electron microscopes, a SAXS, light scattering, and an atomic force microscope). I downloaded the virtual appliance from the website and installed it in virtualbox.
(My system: Ubuntu 11.10).

I followed the instructions on the website (http://www.openmicroscopy.org/site/prod ... _appliance) and everything went fine until the login.

I found myself in a terminal. I could login (root/swordfish) and got to a command line prompt. However, the instructions somehow imply a virtual interface (eg "Click the spanner icon situated above the password box..."). This virtual machine is a debian system, but it seems to have no desktop desktop installed. Is this correct? So the question is: how do I get this OMERO running and tested in the virtual appliance?
I could off course install a desktop (I'd prefer gnome), but the first sentence of the site "The OMERO virtual appliance is a quick, easy, & lo-cost way to try out OMERO.server on your laptop or desktop" would be rather misleading.

Anyway, thanks in advance for the help!

Dimitri Vanhecke
Posts: 15
Joined: Wed Jan 18, 2012 8:03 am

Re: virtual appliance - help

Postby jmoore » Wed Jan 18, 2012 8:26 am

Hi Dimitri,

the VM is intended to only provide the server application. Since there is no data in the VM itself, having the clients on the Debian desktop would do you little good. Instead, you should install the OMERO clients on your real (non-VM) desktop or even on another, external machine and follow the section titled "Working with the OMERO.VM".

Clients can be downloaded from: https://www.openmicroscopy.org/site/sup ... /downloads

More detailed instructions are available under: https://www.openmicroscopy.org/site/sup ... ng-started

Hope that helps.

User avatar
Site Admin
Posts: 1591
Joined: Fri May 22, 2009 1:29 pm
Location: Germany

Re: virtual appliance - help

Postby Vanhecke » Fri Jan 20, 2012 1:53 pm

Off course ...

However, OMERO is not up and running yet. The VM starts nicely, and I can login using the command line (user: omero/ pw: omero) I downloaded the client (insight) and started it (with the vm running). I added the localhost (4064) and tried to login (omero/omero). I got:

Failed to log onto OMERO. Please check user name and/or password or try again later.

I tried to logon with the root account (insight), which also works fine for the VM. All 4 possibilities (Root or user in VM, root and user in client) give the same error. I got the same error using the importer.

I hope I did not oversaw another obvious thing. In summary, this is what I have done.
- I downloaded and installed the VM, ran it an logged on.
- I downloaded the client to my host system, ran insight and added the localhost:4064 server

The VM portforwarding settings were default set in the VM. They are exactly as in the description.

So, again: If somebody knows what I did wrong... all help is welcome.

Dimitri Vanhecke
VM running, client login
omero.png (156.26 KiB) Viewed 6023 times
Posts: 15
Joined: Wed Jan 18, 2012 8:03 am

Re: virtual appliance - help

Postby wmoore » Fri Jan 20, 2012 2:06 pm

The login you need to use in Insight is the "root" account (root / omero) ?

EDIT - Sorry, having read your post a little more carefully, you've tried that already? Or did you try root /swordfish? The docs are a bit confusing actually!
User avatar
Team Member
Posts: 674
Joined: Mon May 18, 2009 12:46 pm

Re: virtual appliance - help

Postby simon » Fri Jan 20, 2012 5:47 pm

Hi Dimitri,

If you are going to connect from your host machine to the OMERO.server using OMERO.insight then there is only a single account that you can use which has the following credentials; U: root P: omero

The other two accounts are for the Linux installation in the VM, a root and user account respectively, and have no connection to the OMERO accounts. NB. Obviously I need to make the documentation a little better here :D

If the above does not work then I need a little more information to help track down the problem, so first off, some diagnostics:

(1) Can you log into the console of the running VM using U: root P: swordfish then run the following command:
Code: Select all

and post the results. It could be that VirtualBox has failed to supply an IP address as the DHCP server in VirtualBox can be flaky.

(2) Do you have OMERO.server running in your host machine? If you do then this will conflict with the port-forwarding settings for the VM which use the same port numbers. If so then I can help you to change the port forwarding numbers to avoid the conflict.

Please try out my suggestions and get back to me. If they work then everything is cool, and if not, then I can help you get everything working.

Posts: 7
Joined: Thu Mar 17, 2011 11:33 am
Location: University of Dundee

Re: virtual appliance - help

Postby Vanhecke » Mon Jan 23, 2012 8:37 am

Hi Simon,

Thanks a lot for the help.
I tried the following now:
VM (OMERO.server) login: Root/swordfish; OMERO.Client login: root / omero -> failed to connect...
VM (OMERO.server) login: omero/omero; OMERO.Client login: root / omero -> failed to connect...

With this, I have exhaused all possible combinations.

I logged onto the server (VM) with root/swordfish and ran ifconfig. The output is attached as a screen shot (sorry, couldn't make a copy/paste from the VM).

Yes, I run the OMERO.client and the OMERO.server on the same machine (totally locally, no intranet/internet involved). The server runs in VirtualBox (4.1.8) within Ubuntu 11.10. The machine was installed last week (i.e. fresh install). I added a screen shot of the VirtualBox network settings as well.


Dimitri Vanhecke
Screenshot of the network settings of VirtualBox for the omero VM
vm_network_settings.png (83.35 KiB) Viewed 6011 times
Screenshot of the running VM, ifconfig command output
vm_ifconfig_output.png (16.26 KiB) Viewed 6011 times
Posts: 15
Joined: Wed Jan 18, 2012 8:03 am

Re: virtual appliance - help

Postby simon » Mon Jan 23, 2012 12:00 pm

Hi Dimitri,

From the output of ifconfig, it looks as though your VM doesn't have an IP address so the VM is not contactable from the outside world, i.e. your host OS. This is an intermittent VirtualBox bug which keeps resurfacing with various versions of the package, for some reason the VirtualBox DHCP server fails to supply an IP address to the VM during boot. Because of the type of networking that we have set up for the OMERO.VM you should always get the IP address allocated to the VM by VirtualBox.

The easiest fix is to log into the console of your VM and get dhclient to force the current IP lease to be expired then request a new IP, e.g.

$ dhclient -r
$ dhclient eth0

If you then use ifconfig again you should see an entry for and you should be able to connect to the VM using SSH/OMERO.clients as indicated in the documentation.

If you still cannot access the VM using OMERO.clients then please try rebooting and repeating the process, as sometimes this causes VirtualBox to allocate an IP address correctly.

If all else fails, please post another capture of the output of ifconfig after using the dhclient commands above.

Please give this a try and get back to me and I will update the documentation to reflect this.

Posts: 7
Joined: Thu Mar 17, 2011 11:33 am
Location: University of Dundee

Re: virtual appliance - help

Postby Vanhecke » Mon Jan 23, 2012 2:04 pm

Hi Simon,

The good news: I've got it working!

Now, for future reference, and potential users, I have logged what I have done. I do not know if every step is absolutely necessary, but this is what I did:

1) start omero-vm.server from virtualbox
2) login using the root (pw: swordfish) user account
3) check the internet connections: type "ifconfig" in the terminal. There should be an entry eth0. As Simon was hinting at: this one was missing in my case.
4) Check this blogentry: http://pyarra.blogspot.com/2010/03/virt ... -gone.html
Basically, you have to remove a file: "rm /etc/udev/rules.d/70-persistent-net.rules"
5) Reboot the virtual machine (type "shutdown -r now")
6) You should now have the eth0 network adapter (check "ifconfig"). The mac address should be corresponding to the mac address of your vm settings (in Virtual box, click your virtual machine > settings Y Network tab > Adapter 1 tab > advanced -> this MAC address should be the one you by typing "ifconfig".
7) in my case, no IP address go assigned to the eth0 adapter: type "ip addr show eth0". the second line should start with "inet ip". If not: re-assign a DHCP client:
type "dhclient -r"
followed by "dhclient eth0"
8) check if you have the IP address correctly assigned ("ip addr show eth0")
9) move your attention to the host. Start OMERO.insight and login with root (pw: omero).

Posts: 15
Joined: Wed Jan 18, 2012 8:03 am

Re: virtual appliance - help

Postby simon » Mon Jan 23, 2012 3:21 pm

Great news Dimitri,

Although wiping the udev rules has worked in this case, I am uncomfortable with calling it a solution as this particular problem is caused by a VirtualBox issue with the DHCP server for NAT'ed networks. I have found that removing the udev rules isn't a reliable solution, i.e. it works 9 times out of 10 but so does a straight reboot of the VM which makes me think that it works as a side effect by increasing the boot time rather than using the udev rules from previous boots. I think that very small extra delay in booting after removing the udev rules is sufficient to give the VirtualBox DHCP server enough time to work properly.

That said, an approach which I have found to be reliable though is releasing & renewing the DHCP lease from within the VM. Unfortunately this means that you can't start up the VM headless as you need console access when the problem occurs. Anyhow, I am really hoping the Oracle get this fixed properly at some point.

In the meantime, I am glad that you have your OMERO.server up and running.

Posts: 7
Joined: Thu Mar 17, 2011 11:33 am
Location: University of Dundee

Re: virtual appliance - help

Postby abradd » Mon Jun 04, 2012 12:29 am

Hey everyone,

I am having a similar issue to Dmitri, but cannot seem to resolve the issue.

I have installed the VM as recommended, with all the settings given in the guide.

I still get the unable to login error though. I have tried all the recommended solutions. I sign in as admin (u: root p: swordfish)
I check my connectioned with ifconfig and eth0 is present with the correct ip address.
The MAC adress matches.

I have checked the ports and both appear to have virtualbox listening on them, but still when I use (u: root p: omero) I get a login error. It tells me to check username and password?

I am uncertain as to what I should do next.


Posts: 2
Joined: Mon Jun 04, 2012 12:16 am


Return to User Discussion

Who is online

Users browsing this forum: Google [Bot] and 1 guest