Page 1 of 1

Large (>1GB) stitched .oir files cannot be opened

PostPosted: Thu Jun 14, 2018 3:01 pm
by phant0msp1ke

My name is Alex, currently PhD student in the University of Oxford.

This topic is similar to another one (viewtopic.php?f=13&t=8362&p=18787&hilit=martin#p18787) however my problem is slightly different so this is not a duplication.

I have uploaded an example file using this link: and the file is called: Example_image_1.oir. Would it be also useful to upload a smaller file that works as a "positive control"?

I have the following problem with Olympus .oir files:

When the .oir file is large (>1GB) and consisting of stitched images it won't open via the Bio-formats FIji plug-in. When I try to open it, FIji says "Reading file header" but it never finishes reading and opening the file.

I have acquired this file using an Olympus microscope FV 3000. When you are imaging a large object (in my case a fluorescent brain slice) you can choose an option to take many images that tile the entire object and then stitch them together into a single image. This is what I mean by a stitched image.

The Bio-formats Fiji plug-in works fine for files which are stitched AND <1GB OR >1GB and NOT stitched but not for stitched AND >1GB.

Another thing that I have tried is using the Bio-formats Command line tools, specifically the function bfconvert to convert the .oir file to .ome.tiff or .tiff. Analogously to the Fiji plug-in that worked for files which are stitched AND <1GB OR >1GB and NOT stitched but not for stitched AND >1GB. What happens is that when I run the bfconvert it just gets stuck and doesn't output anything with the large stitched files.

A bit more info:

-> The issue has been reproduced on both Linux Ubuntu 16.04 LTS and macOS High Sierra version 10.13.5

-> On both of them I am running Fiji (ImageJ) version 1.52d and Java 1.8.0_172 (64-bit)

-> The Bio-formats plug-in on both of them is Release 5.8.2 Build date: 20.04.2018

-> All my images are collected on the Olympus FV 3000 using the FluoView software with air objective x20. The size of the images vary as they are made by stitching a variable number of smaller images. The smaller images are X:Y - 2048:2048 pixels, pixel type: uint16, have 5-8 z slices, no time series.

-> The command line tools were downloaded from here: ... index.html

As a general note, I realize that the problem probably lies mostly within Olympus and their software engineers for not thinking about this problem when designing the .oir files. However, I would still appreciate it if you could try to find a workaround either via the Fiji plug-in or the command line tools (thinking mostly bfconvert) allowing me to convert from .oir -> .ome.tiff/.tiff. It might be worth getting in touch with the Olympus software developers too?

Thank you for your time and your help. Feel free to ask me any questions either here or email/PM if something is not clear.

Best wishes,


Re: Large (>1GB) stitched .oir files cannot be opened

PostPosted: Fri Jun 15, 2018 3:30 pm
by dgault
Hi Alex,

Thank you for the detailed report and for providing a sample file. I have been able to test the file provided and reproduce the same issue, from debugging I am able to see the point in which the parsing has become stuck.

I have opened a PR to test a potential solution against the other OIR files in our repository:

David Gault

Re: Large (>1GB) stitched .oir files cannot be opened

PostPosted: Wed Jul 04, 2018 4:49 pm
by phant0msp1ke
Hi David,

Thank you very much for the quick reply and for your help!

Sorry I didn't reply earlier but for some reason I didn't get notification (maybe you need to set it up somewhere?).

Has there been any development on this issue? Is there anything I can do to help you guys?

Best wishes,


Re: Large (>1GB) stitched .oir files cannot be opened

PostPosted: Thu Jul 05, 2018 8:29 am
by dgault
There was an update to the OIR Reader which should prevent this issue included in the release of Bio-Formats 5.9.0 which is available now

If you are using FIJI then it should also be available via the Java 8 update site.