We're Hiring!

Ice.ConnectionRefusedException at first login

Having a problem deploying OMERO? Here's a great place to start.
Please note:
The OMERO.server installation documentation begins here and you can find OMERO.web deployment documentation here.

Ice.ConnectionRefusedException at first login

Postby kmdouglass » Fri Mar 21, 2014 9:00 am

Hi all,
Well I've finally got the server installed and running and am now at the step in the Windows server documentation where I should log into the server.

Unfortunately, I receive the following error when I attempt to login from the console:
Code: Select all
C:\OMERO.server>bin\omero login
Server: [localhost]
Username: [douglass]root
Password:
Ice.ConnectionRefusedException: localhost isn't running


I cannot log in with the OMERO.insight client either.

I'm baffled by this error since I can't seem to find much information about it in the OMERO documentation or user community. I have followed all the default settings in the documentation except, of course, for the usernames and passwords.

One lead I have is that I should uninstall PostgreSQL 9.3.3 and try 9.3.1 instead since it has been tested with OMERO.

Can anyone help out? Thanks!

Kyle

----------

Code: Select all
C:\OMERO.server>bin\omero admin diagnostics

================================================================================

OMERO Diagnostics 5.0.0-ice34-b19
================================================================================


Commands:   java -version                  1.7.0     (C:\Windows\SysWOW64\java.E
XE)
Commands:   python -V                      2.6.6     (C:\Python26\python.EXE)
Commands:   icegridnode --version          3.4.2     (C:\ZeroC\Ice-3.4.2\bin\x64
\icegridnode.EXE)
Commands:   icegridadmin --version         3.4.2     (C:\ZeroC\Ice-3.4.2\bin\x64
\icegridadmin.EXE)
Commands:   psql --version                 9.3.3     (C:\Program Files\PostgreSQ
L\9.3\bin\psql.EXE)

Server:     icegridnode                    running
Server:     Blitz-0                        active (pid = 216704, enabled)
Server:     DropBox                        inactive (disabled)
Server:     FileServer                     active (pid = 216720, enabled)
Server:     Indexer-0                      active (pid = 216764, enabled)
Server:     MonitorServer                  inactive (disabled)
Server:     OMERO.Glacier2                 inactive (enabled)
Server:     OMERO.IceStorm                 active (pid = 216848, enabled)
Server:     PixelData-0                    active (pid = 216892, enabled)
Server:     Processor-0                    active (pid = 216932, enabled)
Server:     Tables-0                       active (pid = 216988, enabled)
Server:     TestDropBox                    inactive (enabled)
Server:     OMERO.master                   active (running as LocalSystem)

OMERO:      SSL port                       4064
OMERO:      TCP port                       4063

Log dir:    C:\OMERO.server\var\log        exists

Log files:  Blitz-0.log                    181.0 KB      errors=52   warnings=0

Log files:  DropBox.log                    3.0 KB        errors=12   warnings=0

Log files:  FileServer.log                 1.0 KB
Log files:  Indexer-0.log                  209.0 KB      errors=70   warnings=4

Log files:  MonitorServer.log              3.0 KB        errors=8    warnings=0

Log files:  OMEROweb.log                   n/a
Log files:  PixelData-0.log                114.0 KB      errors=70   warnings=4

Log files:  Processor-0.log                32.0 KB       errors=16   warnings=9

Log files:  Tables-0.log                   34.0 KB       errors=16   warnings=9

Log files:  TestDropBox.log                n/a
Log files:  master.err                     0.0 KB
Log files:  master.out                     0.0 KB
Log files:  Total size                     0.58 MB


Environment:OMERO_HOME=(unset)
Environment:OMERO_NODE=(unset)
Environment:OMERO_MASTER=(unset)
Environment:OMERO_TEMPDIR=(unset)
Environment:PATH=C:\Python26;C:\Program Files (x86)\GnuWin32\bin;C:\Program File
s\PostgreSQL\9.3\bin;C:\Windows\SysWOW64;C:\Program Files (x86)\Common Files\Int
el\Shared Libraries\redist\ia32\mpirt;C:\Program Files (x86)\Common Files\Intel\
Shared Libraries\redist\ia32\compiler;C:\Windows\system32;C:\Windows;C:\Windows\
System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Micro
soft\Web Platform Installer\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET We
b Pages\v1.0\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program F
iles\Microsoft Windows Performance Toolkit\;C:\Program Files (x86)\QuickTime\QTS
ystem\;C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\;C:\Program Files\MATLAB\R20
13b\runtime\win64;C:\Program Files\MATLAB\R2013b\bin;C:\ZeroC\Ice-3.4.2\bin\x64;
C:\Ruby193\bin
Environment:ICE_HOME=(unset)
Environment:LD_LIBRARY_PATH=(unset)
Environment:DYLD_LIBRARY_PATH=(unset)

OMERO data dir: 'C:\\OMERO'     Exists? True    Is writable? True
OMERO temp dir: 'C:\Users\douglass\AppData\Roaming\omero\tmp'   Exists? True
Is writable? True   (Size: 0)
OMERO.web status... [NOT STARTED]
kmdouglass
 
Posts: 17
Joined: Mon Mar 10, 2014 2:00 pm
Location: Lausanne, Switzerland

Re: Ice.ConnectionRefusedException at first login

Postby colmeirin » Fri Mar 21, 2014 11:23 am

Hi Kyle,

I'm using postgre 9.3.3 and it's working fine for me.

I've seen in your admin diagnostics that ICE_HOME enviroment variable is not set. I don't know if it has some effect but you could try to set the ICE_HOME enviroment variable to C:\ZeroC\Ice-3.4.2
If you have allready setted restart your server.

Also, you can try to change localhost for 127.0.0.1 in the login process

And make sure that the postgre is runing!

I hope you can resolve this problems soon.

Regards.
colmeirin
 
Posts: 16
Joined: Tue Mar 11, 2014 6:16 pm

Re: Ice.ConnectionRefusedException at first login

Postby kennethgillen » Fri Mar 21, 2014 11:25 am

Hi Kyle,

I'm not sure if Windows Firewall can affect localhost connections, but it's worth ruling that out.

Can you connect with telnet to your OMERO server from the command line? [1]

Code: Select all
telnet localhost 4063

Should connect and return:
IceP


Code: Select all
telnet localhost 4064

Should connect, but you won't see any output. (Unless you connect with OpenSSL's s_client [2])

If it's safe to turn off the Windows Firewall, please do and re-try. If not, please try adding firewall rules for OMERO, allowing connections to tcp/4063, tcp/4064. Please retry the above connection debugging steps if you were able to turn off / add Windows Firewall rules.[3]

[1] These days telnet's not installed by default.
[2] testing OMERO connections with openSSL and telnet
[3] OMERO and Firewalls

Best,

Kenny
User avatar
kennethgillen
Team Member
 
Posts: 241
Joined: Mon Nov 05, 2012 3:39 pm

Re: Ice.ConnectionRefusedException at first login

Postby kmdouglass » Fri Mar 21, 2014 11:41 am

Hi colmeirin and Kenny,

colmeirin wrote:Hi Kyle,

I'm using postgre 9.3.3 and it's working fine for me.

I've seen in your admin diagnostics that ICE_HOME enviroment variable is not set. I don't know if it has some effect but you could try to set the ICE_HOME enviroment variable to C:\ZeroC\Ice-3.4.2
If you have allready setted restart your server.

...

And make sure that the postgre is runing!



Well that was a simple fix. I did not have the Postgre SQL Shell open and running. I opened it and logged in with my SQL user credentials and now can log into the OMERO server from both the command line and OMERO.insight.

I haven't set the ICE_HOME environment variable because, quite frankly, I haven't yet had any errors connected with it :)

Thanks for the help on this one!

Kyle
kmdouglass
 
Posts: 17
Joined: Mon Mar 10, 2014 2:00 pm
Location: Lausanne, Switzerland


Return to Installation and Deployment

Who is online

Users browsing this forum: No registered users and 1 guest

cron