We're Hiring!

Problems with upgrading 5.1.2 to 5.2

Having a problem deploying OMERO? Here's a great place to start.
Please note:
You can find examples of server set-ups in use by the OMERO community on this documentation page. If you would like to share details of your deployment to help advise the community, there is a questionnaire which we would very much appreciate you completing.

Problems with upgrading 5.1.2 to 5.2

Postby phm » Wed Nov 04, 2015 11:27 am

Hi,
I have some problems after upgrading from 5.1.2 to 5.2. I'm under CentOS 6.5, the upgrade process was nice before I install Django 1.8 required by Omero server 5.2. Than means the Omero server started incorrectly I was able to connect to the server via Insight except I can't start the web server. So I install python 2.7.9 and mod_wsgi required by Django 1.8 alternatively to 2.6 installed to avoid yum break. And them install Django with pip. However, when I try to start the web server or when I run any omero commands I get the same error :
[omero@omero ~]$ omero web start
********************************************************************************

ERROR: Could not import omero.cli! (No module named Ice)

This means that your installation is incomplete. Contact
the OME mailing lists for more information:

http://www.openmicroscopy.org/site/community

If you are building from source, please supply the build log
as well as which version you are building from. If you
downloaded a distribution, please provide which link you
used.

********************************************************************************

Debugging Info:
--------------
CWD=/home/omero
VERSION=2.7.9 (default, Nov 4 2015, 11:40:46) [GCC 4.4.7 20120313 (Red Hat 4.4.7-16)]
OMERO_HOME=None
PYTHONPATH=['/opt/OMERO.server/lib/python', '/opt/OMERO.server/var/lib', '/opt/OMERO.server-5.2.0-ice35-b12/bin', '/usr/local/lib/python2.7/site-packages/distribute-0.7.3-py2.7.egg', '/opt/distribute-0.7.3', '/usr/local/lib/python2.7/site-packages/pip-7.1.2-py2.7.egg', '/usr/local/lib/python27.zip', '/usr/local/lib/python2.7', '/usr/local/lib/python2.7/plat-linux2', '/usr/local/lib/python2.7/lib-tk', '/usr/local/lib/python2.7/lib-old', '/usr/local/lib/python2.7/lib-dynload', '/usr/local/lib/python2.7/site-packages', '/opt/OMERO.server/lib/fallback']

I didn't restart the Omero server ( it's not possible) and didn't reboot the machine (I'm afraid that the omero server break)

Philippe
phm
 
Posts: 149
Joined: Tue Mar 19, 2013 3:39 pm

Re: Problems with upgrading 5.1.2 to 5.2

Postby manics » Wed Nov 04, 2015 5:03 pm

Hi Philippe

Ice is linked to a particular Python version, so you'll need to recompile it following the instructions in:
https://www.openmicroscopy.org/site/sup ... ml#ice-3-5

Simon
User avatar
manics
Team Member
 
Posts: 210
Joined: Mon Oct 08, 2012 11:01 am
Location: Dundee

Re: Problems with upgrading 5.1.2 to 5.2

Postby phm » Thu Nov 05, 2015 10:16 am

Hi Simon,

Thanks for the link. However, I recompiled Ice against python 2.7.9 and I have the same error message. Should I do a reboot of the system ?

Philippe
phm
 
Posts: 149
Joined: Tue Mar 19, 2013 3:39 pm

Re: Problems with upgrading 5.1.2 to 5.2

Postby manics » Thu Nov 05, 2015 10:31 am

Did you setup the required environment before starting omero? If that doesn't help could you paste the output of
Code: Select all
env

when logged on as the omero system user?

Thanks

Simon
User avatar
manics
Team Member
 
Posts: 210
Joined: Mon Oct 08, 2012 11:01 am
Location: Dundee

Re: Problems with upgrading 5.1.2 to 5.2

Postby phm » Thu Nov 05, 2015 10:47 am

Hi Simon,

You right I forgotten to setup the environment variables. Now, when I run
omero admin start
No descriptor given. Using etc/grid/default.xml
icegridnode: failure occurred in daemon:
service caught unhandled std::exception:
SharedDbEnv.cpp:620: Freeze::DatabaseException:
DbEnv::open: DB_RUNRECOVERY: Fatal error, run database recovery
0 IceUtil::Exception::Exception(char const*, int) in /opt/Ice-3.5.1/lib64/libIceUtil.so.35
1 Ice::LocalException::LocalException(char const*, int) in /opt/Ice-3.5.1/lib64/libIce.so.35
2 Freeze::DatabaseException::DatabaseException(char const*, int, std::string const&) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
3 Freeze::SharedDbEnv::SharedDbEnv(std::string const&, IceInternal::Handle<Ice::Communicator> const&, DbEnv*) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
4 Freeze::SharedDbEnv::get(IceInternal::Handle<Ice::Communicator> const&, std::string const&, DbEnv*) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
5 Freeze::createConnection(IceInternal::Handle<Ice::Communicator> const&, std::string const&) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
6 FreezeDB::ConnectionPool::newConnection() in /opt/Ice-3.5.1/lib64/libIceGridFreezeDB.so.35
7 FreezeDB::ConnectionPool:�


omero admin diagnostics
================================================================================
OMERO Diagnostics 5.2.0-ice35-b12
================================================================================

Commands: java -version 1.7.0 (/usr/bin/java)
Commands: python -V 2.7.9 (/usr/local/bin/python -- 2 others)
Commands: icegridnode --version 3.5.1 (/opt/Ice-3.5.1/bin/icegridnode -- 2 others)
Commands: icegridadmin --version 3.5.1 (/opt/Ice-3.5.1/bin/icegridadmin -- 2 others)
Commands: psql --version 9.4.5 (/usr/pgsql-9.4/bin/psql -- 2 others)

Server: icegridnode not started

Log dir: /opt/OMERO.server/var/log exists
Log files: Blitz-0.log 3.0 MB errors=177 warnings=38
Log files: DropBox.log 4.0 KB errors=2 warnings=2
Log files: FileServer.log 0.0 KB
Log files: Indexer-0.log 554.0 KB errors=553 warnings=44
Log files: MonitorServer.log 1.0 KB
Log files: OMEROweb.log n/a
Log files: PixelData-0.log 545.0 KB errors=552 warnings=44
Log files: Processor-0.log 126.0 KB errors=40 warnings=4
Log files: Tables-0.log n/a
Log files: TestDropBox.log n/a
Log files: master.err 3.0 KB errors=2 warnings=10
Log files: master.out 0.0 KB
Log files: Total size 4.51 MB


Environment:OMERO_HOME=(unset)
Environment:OMERO_NODE=(unset)
Environment:OMERO_MASTER=(unset)
Environment:OMERO_USERDIR=(unset)
Environment:OMERO_TMPDIR=/tmp
Environment:PATH=/opt/Ice-3.5.1/bin:/usr/pgsql-9.4/bin/:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/dell/srvadmin/bin:/opt/OMERO.server/bin:/opt/dell/srvadmin/sbin:/usr/java/latest/bin
Environment:PYTHONPATH=/opt/Ice-3.5.1/python:
Environment:ICE_HOME=(unset)
Environment:LD_LIBRARY_PATH=/opt/Ice-3.5.1/lib64:/opt/Ice-3.5.1/lib:
Environment:DYLD_LIBRARY_PATH=(unset)

Cannot list deployed applications.
OMERO data dir:'/OMERO' Exists? True Is writable? True
OMERO temp dir:'/tmp' Exists? True Is writable? True (Size: 402766)

JVM settings: Blitz-${index} -Xmx6400m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions
JVM settings: Indexer-${index} -Xmx3200m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions
JVM settings: PixelData-${index} -Xmx4800m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions
JVM settings: Repository-${index} -Xmx3200m -XX:MaxPermSize=1g -XX:+IgnoreUnrecognizedVMOptions

OMERO.web status... [NOT STARTED]
Django version: 1.8.5



The problem may be come that I have 2 python versions 2.7 in /usr/local and 2.7.9 in /opt
echo $PATH
/opt/Ice-3.5.1/bin:/usr/pgsql-9.4/bin/:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/dell/srvadmin/bin:/opt/OMERO.server/bin:/opt/dell/srvadmin/sbin:/usr/java/latest/bin
echo $PYTHONPATH
/opt/Ice-3.5.1/python:
ls /usr/local/lib/python2.7/site-packages/
distribute-0.7.3-py2.7.egg django Django-1.8.5.dist-info easy-install.pth numpy numpy-1.10.1-py2.7.egg-info pip-7.1.2-py2.7.egg README setuptools.pth
phm
 
Posts: 149
Joined: Tue Mar 19, 2013 3:39 pm

Re: Problems with upgrading 5.1.2 to 5.2

Postby manics » Thu Nov 05, 2015 11:30 am

It looks like there are some stale files left behind. Could you delete the OMERO.server var/master directory and try starting OMERO?
User avatar
manics
Team Member
 
Posts: 210
Joined: Mon Oct 08, 2012 11:01 am
Location: Dundee

Re: Problems with upgrading 5.1.2 to 5.2

Postby phm » Thu Nov 05, 2015 11:35 am

manics wrote:It looks like there are some stale files left behind. Could you delete the OMERO.server var/master directory and try starting OMERO?

Hi manics,

Same thing
rm -rf /opt/OMERO.server/var/master/
omero admin start
Creating /opt/OMERO.server/var/master
No descriptor given. Using etc/grid/default.xml
icegridnode: failure occurred in daemon:
service caught unhandled std::exception:
SharedDbEnv.cpp:620: Freeze::DatabaseException:
DbEnv::open: DB_RUNRECOVERY: Fatal error, run database recovery
0 IceUtil::Exception::Exception(char const*, int) in /opt/Ice-3.5.1/lib64/libIceUtil.so.35
1 Ice::LocalException::LocalException(char const*, int) in /opt/Ice-3.5.1/lib64/libIce.so.35
2 Freeze::DatabaseException::DatabaseException(char const*, int, std::string const&) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
3 Freeze::SharedDbEnv::SharedDbEnv(std::string const&, IceInternal::Handle<Ice::Communicator> const&, DbEnv*) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
4 Freeze::SharedDbEnv::get(IceInternal::Handle<Ice::Communicator> const&, std::string const&, DbEnv*) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
5 Freeze::createConnection(IceInternal::Handle<Ice::Communicator> const&, std::string const&) in /opt/Ice-3.5.1/lib64/libFreeze.so.35
6 FreezeDB::ConnectionPool::newConnection() in /opt/Ice-3.5.1/lib64/libIceGridFreezeDB.so.35
7 FreezeDB::ConnectionPool:�
phm
 
Posts: 149
Joined: Tue Mar 19, 2013 3:39 pm

Re: Problems with upgrading 5.1.2 to 5.2

Postby manics » Thu Nov 05, 2015 11:46 am

OK... maybe delete the whole of var/ ? Move/backup your var/logs if you think they'll be useful.
User avatar
manics
Team Member
 
Posts: 210
Joined: Mon Oct 08, 2012 11:01 am
Location: Dundee

Re: Problems with upgrading 5.1.2 to 5.2

Postby phm » Thu Nov 05, 2015 11:58 am

manics wrote:OK... maybe delete the whole of var/ ? Move/backup your var/logs if you think they'll be useful.


Thanks a lot it is working now, Ouf !
Now I have to fix the Omero web part, it return
omero web start
Traceback (most recent call last):
File "manage.py", line 56, in <module>
execute_from_command_line(sys.argv)
File "/opt/rh/python27/root/usr/lib/python2.7/site-packages/Django-1.8.6-py2.7.egg/django/core/management/__init__.py", line 354, in execute_from_command_line
utility.execute()
File "/opt/rh/python27/root/usr/lib/python2.7/site-packages/Django-1.8.6-py2.7.egg/django/core/management/__init__.py", line 328, in execute
django.setup()
File "/opt/rh/python27/root/usr/lib/python2.7/site-packages/Django-1.8.6-py2.7.egg/django/__init__.py", line 18, in setup
apps.populate(settings.INSTALLED_APPS)
File "/opt/rh/python27/root/usr/lib/python2.7/site-packages/Django-1.8.6-py2.7.egg/django/apps/registry.py", line 89, in populate
"duplicates: %s" % app_config.label)
django.core.exceptions.ImproperlyConfigured: Application labels aren't unique, duplicates: figure


It's may be due to the figure script which is come from old server version ?

Philippe
phm
 
Posts: 149
Joined: Tue Mar 19, 2013 3:39 pm

Re: Problems with upgrading 5.1.2 to 5.2

Postby manics » Thu Nov 05, 2015 12:09 pm

Yes, it sounds like an invalid config. Could you paste the output of
Code: Select all
omero config get --hide-password


Thanks, Simon
User avatar
manics
Team Member
 
Posts: 210
Joined: Mon Oct 08, 2012 11:01 am
Location: Dundee

Next

Return to Installation and Deployment

Who is online

Users browsing this forum: Bing [Bot] and 1 guest